Connectivity issues
Incident Report for Proxyclick
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 14, 2018 - 09:15 CET
Monitoring
Services are back up. We are monitoring all services before closing this incident.
Posted 4 months ago. Mar 14, 2018 - 08:20 CET
Investigating
We're currently noticing connectivity issues impacting our services. We're investigating and will post updates on this page.
Posted 4 months ago. Mar 14, 2018 - 07:56 CET