Connectivity issue
Incident Report for Proxyclick
Resolved
The incident is closed. We apologize for any inconvenience caused.
Posted about 1 year ago. Sep 22, 2017 - 16:07 CEST
Monitoring
We have fixed the issue and are monitoring the situation.
Posted about 1 year ago. Sep 22, 2017 - 16:01 CEST
Investigating
Some users currently experience issues connecting to the Dashboard. We are investigating and will post updates on this page. Please contact us at support@proxyclick.com if you have any questions.
Posted about 1 year ago. Sep 22, 2017 - 15:54 CEST