Delays in sending email notifications
Incident Report for Proxyclick
Resolved
The issue has been resolved and all delayed emails have been sent. Please contact us at support@proxyclick.com if you have any questions.
Posted 2 months ago. Jun 13, 2018 - 15:56 CEST
Identified
Some emails are currently sent with a delay. We identified the issue and the emails are currently dequeuing.
Posted 2 months ago. Jun 13, 2018 - 14:55 CEST
This incident affected: Mail.