Slow loading of Dashboard
Incident Report for Proxyclick
Resolved
All systems are back to normal. We close this incident.
Posted over 1 year ago. Jul 10, 2017 - 16:33 CEST
Monitoring
The issue has been fixed. All systems are back to normal. We are monitoring.
Posted over 1 year ago. Jul 10, 2017 - 16:26 CEST
Investigating
Some users currently experience delays in accessing the Dashboard. We are investigating and will post updates on this page.
Posted over 1 year ago. Jul 10, 2017 - 16:22 CEST