Delays in sending email notifications
Incident Report for Proxyclick
Resolved
Our team has monitored system performance and confirms this incident is resolved. We apologize for any inconvenience this caused. Please reach out to our support@proxyclick.com team if you have any questions.
Posted 10 months ago. Sep 25, 2017 - 15:58 CEST
Monitoring
Issue has been fixed. Emails that were queued are being processed.
Posted 10 months ago. Sep 25, 2017 - 15:55 CEST
Investigating
Some emails notifications are currently delayed. The team is currently analyzing the issue. We'll post updates on this page.

Text messages are sent normally.
Posted 10 months ago. Sep 25, 2017 - 15:49 CEST