Network connectivity issues
Incident Report for Proxyclick
Resolved
Due to a DNS* problem at our hosting provider, some users might have encountered connectivity issues to access our services over the last hour. This problem is now solved. We do apologize for any inconvenience caused. Please let us know if you have any questions. You can reach us at support@proxyclick.com.

(*) Domain Naming System (DNS) is a service that allows your devices to locate our application on the internet.
Posted Jan 06, 2017 - 20:35 CET
Monitoring
Access to our services is now restored. We are monitoring.
Posted Jan 06, 2017 - 20:13 CET
Investigating
We are hearing reports that our services are not accessible for the moment. We are investigating.
Posted Jan 06, 2017 - 19:37 CET