Slow connection to Dashboard
Incident Report for Proxyclick
Resolved
We confirm this issue is closed and apologize for any inconvenience. Please contact us at support@proxyclick.com if you have any questions.
Posted 2 months ago. Oct 09, 2017 - 10:39 CEST
Monitoring
The system is fully operational again. We are monitoring before closing this issue.
Posted 2 months ago. Oct 09, 2017 - 10:23 CEST
Investigating
Some users report slow connection to Dashboard. We are investigating and will post status updates on this page.
Posted 2 months ago. Oct 09, 2017 - 10:02 CEST