Connectivity issue
Incident Report for Proxyclick
Resolved
The connectivity issue has been resolved at around 9:40 am (UTC). All systems function normally since then. We do apologize for the inconvenience. Please contact us at support@proxyclick.com if you have any questions.
Posted about 1 year ago. Jul 05, 2017 - 12:14 CEST
Investigating
Some users currently experience issues connecting to the Dashboard. We are investigating and will post updates on this page. Please contact us at support@proxyclick.com if you have any questions.
Posted about 1 year ago. Jul 05, 2017 - 11:34 CEST