Marketplace website is currently unavailable
Incident Report for Proxyclick
Resolved
Our Marketplace is now available. Maintenance has been completed and new integrations can be added to your Proxyclick account.
Posted Feb 26, 2020 - 11:16 CET
Investigating
We are currently providing maintenance to our Marketplace website. This process is estimated to last 15 minutes and new integrations will not be available during this time.

Please note that existing and operation integrations will not be impacted.
Posted Feb 26, 2020 - 11:02 CET
This incident affected: Dashboard.