Exports may be requested but not received

Incident Report for Eptura Visitor

Resolved

This incident has been resolved and reports are currently being processed.
Posted Jul 08, 2021 - 18:21 UTC

Investigating

We are currently investigating an issue where certain reports may not be sent when requested via the Export option.
Posted Jul 08, 2021 - 10:17 UTC
This incident affected: Exports.