Kiosk not loading
Incident Report for Proxyclick
Postmortem

Root Cause Analysis:
On November 21, 2023 it was reported that certain kiosk apps on versions v4.1.0 to v4.1.12 could not sync to new or existing Proxyclick locations. All kiosk apps already synced and active on locations were unaffected.

 

A startup dependency hosted by a 3rd party service was unavailable due to a data center outage, which prevented the completion of the kiosk app startup process.

 

Preventative Action:
A new version (4.1.13) has been released by Proxyclick Engineering which removes the dependency on the 3rd party service.

Posted Dec 11, 2023 - 12:54 CET

Resolved
The fix is now released. The latest app version 4.1.13 is now available, please update applications for resolution
Posted Nov 21, 2023 - 17:29 CET
Monitoring
Some customers are facing issues where kiosks are not loading or taking too long to load. It shows online in the dashboard, however, does not load after custom flows.
The issue has been identified and fixed by the engineering team. The update is now pushed to Apple, however, may take up to 24-48 hours to get reviewed and approved.

We apologize for any inconvenience caused by this and appreciate your patience in the matter.
Posted Nov 21, 2023 - 15:34 CET
This incident affected: Dashboard, SMS, Mail, Slack, Skype for Business, API, Webhooks, Box integration, Dropbox integration, OneDrive integration, Calendar integration, Salesforce integration, Exports, and Proovr.