Issues with accessing Dashboard

Incident Report for Eptura Visitor

Resolved

This incident has been resolved. Details will be posted as soon as available.
Posted Oct 10, 2019 - 11:54 UTC

Monitoring

A fix has been implemented, we continue to monitor this issue.
Posted Oct 10, 2019 - 09:09 UTC

Update

We are continuing to investigate this issue.
Posted Oct 10, 2019 - 09:01 UTC

Investigating

We are currently investigating an issue impacting access to our Dashboard
Posted Oct 10, 2019 - 08:45 UTC
This incident affected: Dashboard.