QR Code Printing Issue in Kiosk Version V4.1.27

Incident Report for Eptura Visitor

Update

We are currently still awaiting final approval from Apple.

In the meantime, we recommend using the following workaround: please register visitors in advance to ensure QR code badges are generated correctly.

We apologize for the inconvenience and appreciate your continued patience. Restoring full functionality remains our top priority.

Our next update will be provided at 2:30 AM UTC.

Thank you for your understanding.
Posted Jul 18, 2025 - 22:39 UTC

Update

Workaround: We’ve confirmed that this issue impacts only unexpected (walk-in) visitors. As a temporary workaround, we recommend registering visits in advance to ensure QR code badges are generated correctly.

Fix: Our engineering team has developed a fix and submitted it for expedited review with the Apple App Review Board. We’ll notify you as soon as the updated version is approved and available for download.

Thank you for your continued patience.

Next Update in 4 hours.
Posted Jul 18, 2025 - 10:49 UTC

Identified

We are currently investigating an issue affecting the generation of printed QR codes in the latest production release of our Kiosk software (Version V4.1.27, released July 17, 2025).

Our engineering team is actively working on a fix. In the meantime, if you have not yet updated to this version, we recommend pausing the update to avoid disruption.

We sincerely apologize for the inconvenience and appreciate your patience. Further updates will be posted here as soon as they become available.

Next Update: Within 24 hours
Posted Jul 18, 2025 - 10:07 UTC
This incident affects: Access Control.