Delays in delivering some emails
Incident Report for Proxyclick
Resolved
This incident has been resolved.
Posted Feb 20, 2019 - 18:15 CET
Monitoring
Emails are delivered normally. We're monitoring before closing the issue.
Posted Feb 20, 2019 - 14:12 CET
Identified
We see recent emails are processed normally by our provider. There is still a small number of older emails in the queue.
Posted Feb 20, 2019 - 13:14 CET
Investigating
We're experiencing delays with one of our email processing providers. As a result, some email notifications are delayed. We're in contact with our provider and will provide updates on this page. Other notifications (text/SMS, push, integrations) are not affected by this incident.
Posted Feb 20, 2019 - 12:47 CET
This incident affected: Mail.