Degraded performance of ipad app kiosk
Incident Report for Proxyclick
Postmortem

Root Cause Analysis:
From 12:30 to 15:15 CET certain iPad kiosk apps on versions v4.1.0 (released 28th December 2021) to v4.1.10 (current release) could not sync to new or existing Proxyclick locations. All kiosk apps already synced and active on locations were unaffected.

A startup dependency hosted by a 3rd party service was unavailable due to a data center outage, which prevented the completion of the kiosk app startup process.

Preventative Action:
Proxyclick Engineering will be taking steps to release an updated version of the kiosk app which will not rely on the availability of this service for successful kiosk syncs.

Posted May 17, 2023 - 17:34 CEST

Resolved
This incident has been resolved. RCA to come.
Posted May 17, 2023 - 17:29 CEST
Investigating
We are investigating reports of intermittent connectivity when syncing new iPad app kiosk instances.
Posted May 17, 2023 - 14:45 CEST
This incident affected: iPad app.