Delays on the delivery of email notifications
Incident Report for Proxyclick
Resolved
This incident has been resolved - we will continue to monitor performance. Email notifications delivery is now normalised.
Posted Jan 10, 2020 - 17:38 CET
Investigating
We are currently investigating an issue that may delay the delivery of notifications via email
Posted Jan 10, 2020 - 16:07 CET
This incident affected: Mail.