S2 - Intermittent SSO Service Error

Incident Report for Eptura Visitor

Postmortem

We are grateful for your continued support and loyalty. We value your feedback and appreciate your patience as we worked to resolve this incident.

Type of Event:
S2 - Visitor - Intermittent SSO Service Error

 

Services/Modules Impacted:
Visitor application login (intermittent issue)

 

Root Cause:
One node of SAML connection was not responding and this caused intermittent issue for SSO authentication.

 

Remediation:
The team investigated the issue and identified that there were errors observed in the logs. To resolve the issue, both the notes were restarted. The team monitored application after the restart to ensure that no further errors were logged.

Timeline:

All times listed in UTC

11 Feb 17:32 - Issue Reported to Eptura Support.

12 Feb 02:41 - The support team identified that the issue was intermittent and was caused by Infra related item.

12 Feb 04:41 - Both the nodes were restarted by Eptura CloudOps team which resolved the issue.

 

Total Duration of Event:
11 hours 8 minutes

 

Preventive Action:

Our focus is on enhancing monitoring, refining management processes, and elevating team training.

To mitigate future occurrences, the following measures have been implemented by our CloudOps team:

  • Monitoring of saml.proxyclick.com.
  • Regularly monitoring the page internally that reports errors to the server.
Posted Apr 07, 2025 - 15:12 UTC

Resolved

Users were getting Service Unavailable error while trying to access Eptura Visitor via SSO. The issue was intermittent in nature.
Posted Feb 11, 2025 - 23:30 UTC