Delays on delivery of notification emails
Incident Report for Proxyclick
Resolved
This incident has been resolved and email notifications should start being delivered in a timely manner.
Posted Feb 28, 2020 - 16:46 CET
Update
We are continuing to investigate this issue.

Please note that this is only causing a delay on email notifications. Text messages, push notifications and integrations for check in notifications are fully functional.
Posted Feb 28, 2020 - 15:31 CET
Investigating
We are currently investigating an issue that is causing email notifications to be delayed. No additional impact to the platform is being observed.
Posted Feb 28, 2020 - 14:24 CET
This incident affected: Mail.